Chapter 5 Details of Operation

The basic steps for any F20 measurement are selecting and editing the film structure, taking a
baseline measurement, and then making and evaluating the measurement. The details of each of
these steps are explained below, followed by descriptions of other FILMeasure functions.

5.1 Taking a Baseline

The baseline measurement allows the FILMeasure software to take into account the response
inherent to the F20 reflectance measurement hardware. It does this by measuring a reference sample
and by taking a “dark” reading. If optical constants or very thin films are to be measured, the light
source should be allowed to stabilize at least ten minutes before the baseline is taken, and then
periodically re-taken every 20-30 minutes. A baseline measurement is taken by clicking on the
Baseline button on the main screen and following the prompts. The steps for taking the baseline are
explained in detail here.

The first step is to take a reference spectrum. This done by placing the reference sample (usually
silicon or BK7 glass) on the sample stage and clicking OK when prompted. The reference material
that is used should be selected in the Reference list. If the film structure to be measured has already
been selected from the “Structure:” list, then Autoscale Integration Time can be selected. In some
instances this will not be possible and the instructions for setting the integration time with the
Setup > Data Acquisition box will have to be followed.

The dark scan should be taken with no sample on the stage and the light turned on (so that the light
output remains stable). Most stages have a built-in tilted mirror or other reflector that is used to re-
direct the incident light away from the collection optics. If you are using a movable stage, move this
reflector under the light beam. Click on “OK” to take the dark reading.

After acquiring a baseline the F20 is ready to begin making measurements. To verify that the system
is working properly, you may select Acquire > Do Single Acquisition with the reference sample in
place. You should see the reflectance spectrum of the reference material.

5.2 Editing Film Structures

The film characteristics that are to be measured, and the description of the sample film structure are
specified in the "Edit Structure" dialog box. Dozens of different film structures and their
measurement specifications may be saved using the "Edit Structure" dialog box.
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The "Edit Structure” dialog box is accessed with the "Edit Structure" button on the right-hand side of
the main screen. The "Edit Structure" dialog box lists an initial guess at the specifications of the film
structure to be measured. These specifications include the name of the film structure (which
identifies it in the "Structure:" list), the number of films in the structure, the specifications of
individual films, and the quantities to be measured.

Edit Structure > Adding, Changing, or Deleting a Structure

When the "Edit Structure" dialog box is opened, it shows the stored specifications of the structure
selected from the "Structure:" list, along with any changes made since the program was started.
Changes to the structure selected can be permanently stored by making the desired changes and then
clicking on "Save Changes". New structures may be added to the "Structure:" list by opening the
"Edit Structure” dialog box, entering the name of the new structure in the "Name:" field, setting the
desired specifications, and then clicking on "Save As New". Similarly, a structure may be deleted
(removed from the “Structure:” list) by clicking on the “Delete” button.

Poly/Si02 on Si

Figure 5.1: Edit Structure > Layers window

Edit Structure > Layers: Setting Up a Film Structure

When solving for a parameter, the specifications (d, n, k, roughness) of the known films (including

the incident medium and substrate) must be entered into the proper fields in the "Edit Structure"
dialog box, as well as initial guesses for the values to be measured. The refractive index (n) and
extinction coefficient (k) values for common materials can be selected automatically with the pull-
down menus on the left-hand side of the "Edit Structure" dialog box.

If a material is being measured which is not present in the pop-up material list there are three
possible approaches: a) choose a material in the list which is similar, b) if the material is transparent
(an insulator), select “Enter Refractive Index Value” from the material list and enter a value for the
refractive index (n will automatically be varied by FILMeasure, with the entered value being n at 632
nm), or c) in the Edit > Edit Material Library dialog box, enter the refractive index values for n and k
as a function of wavelength and save the files so that they may be selected as in a).
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Edit Structure > Layers: Choosing Film Properties to be Measured

To measure a film property, check the appropriate box on the right-hand side of the “Layers” field in
the Edit Structure dialog box. In general, thickness values can be measured independently if the n
and k of the layer are specified. However, unless the thickness is extremely well-known, n and k can
not be measured without also measuring thickness. Also, unless the material is a dielectric (k=0), n
and k must be measured together.

As with any measurement, the accuracy of the measured data decreases as the number of measured
values increases. This is especially true here, as changes in d, n, and k can often affect the measured
reflectance spectrum in similar ways. Thus it is best to provide as much information about the film
structure as possible.

Edit Structure > Layers: “Robust Thickness Only” Mode

If thickness is the only property to be measured and the film to be measured is greater than 5000 A
thick, the “Robust Thickness Only” mode may be used. This mode can oftentimes allow for
successful measurements to be made when the reflectance data is affected by non-ideal film
properties, such as non-uniformities and birefringce. In this mode, if the thickness entry field is
empty, FILMeasure will search for the best thickness fit between approximately 20 A and 100 pm
(Caution: Measuring thickness in this mode may take a considerable amount of time.) If a thickness
value is entered, the range of thicknesses tested is constrained by the limits set in the "Constraints"

field.

Edit Structure > Options

Correct setting of the following options will help insure accurate measurements. Many of the
options are set automatically when film information is supplied in the "Edit Structure" dialog box,
and all of them can be saved so that subsequent measurements can be made as quickly and easily as

possible.

Most of the options are self-explanatory: measurements may be made in reflection or transmission
mode; the angle of the incident light may be varied, with normal incidence defined as zero degrees;
and transverse electric and magnetic polarization may be selected when the incident angle is not
ZEero.
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Edit Structure

Figure 5.2: Edit Structure > Options window

Edit Structure > Options: Grid Search for Thickness

There are a number of methods that FILMeasure can use to determine thickness, n, and k. None is
perfect—each is a different trade-off between speed, accuracy, and robustness (i.e., the ability to find
the best solution among many that are nearly as good.) Because thickness can vary over many orders
of magnitude and many near-solutions exist, it is often best to use a very robust method to get close
to the best solution, and then let a more accurate method take over. One very robust method is the
"Grid" method, which can be activated by selecting "Grid Search for Thickness." The Grid method
searches the entire allowed thickness range (as defined by the initial guess and the constraints) to
find the best initial thickness. However, on some very complex spectra, it is possible for the Grid
method to become confused and give the wrong answer. In such cases it is best to measure without
the Grid method by using accurate initial guesses to get close to the final solution.

Edit Structure > Options: Fourier Search for Thickness

The Fourier Transform method is an alternative option to let FILMeasure choose an initial thickness
for analysis. The Fourier Transform method analyzes the oscillations present in the spectrum and
determines the film thicknesses based on the periodicity of those oscillations. It is somewhat less
robust than the Grid method, but is better at finding the correct thickness in cases where the shape of
the initial theoretical spectrum is different than the measured data (i.e., the reflectance spectrum is
non-ideal in some way) or in cases where there is more than one film thickness is being measured.

Edit Structure > Options: Convergence Criteria

This sets the maximum error between the measured and calculated spectra that is attained before the
measurement routines consider the solution final. In most cases a value of 0.005 is sufficient (for
how this is calculated, see Fitting Error in Section 5.3.) For cases where the desired Fitting Error is
not attainable, the value in "Maximum Iterations:" limits the number of iterations performed by the
analysis routine.
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Edit Structure > Options: Models for n and k

When measuring » and k for a film, the general dependence of these values upon wavelength must be
specified. This dependence is determined by the type of material to be measured. For example,
insulators, semiconductors, and metals all have a unique type of n and k wavelength dependence.
Dozens of models for these different dependencies have been proposed and used over the years.
FILMeasure uses a few of the most versatile and accepted of these models. For insulators, the
Cauchy model is used, for semiconductors, either the Amorphous or Bridge-Lorentzian model, and
for metals, the Drude model. These models are selected automatically when a material is chosen
from the Material lists on the "Edit Structure..." dialog box. Other models may also be specified by
selecting them from the "nk Model" box in the "Options..." dialog box.

Edit Structure > Constraints

By setting constraints, the user can limit the possible values of the measured film properties. The
constraints are set in conjunction with the values entered in the Edit Structure > Layers dialog box.
For example, if the initial guess of the measured thickness of a film is 1000 A and the thickness
constraint is set at +/- 50%, FILMeasure will only consider possible thicknesses in the range 500 A
to 1500 A. Constraining the measurement range can speed up the measurements and can also help
exclude non-physical solutions.

5.3 Understanding and Evaluating Measurement Results

Display of Measured Data

Once film structure and measurement information have been entered and baseline spectra taken,
measurements may be made by clicking on the "Measure" button. After measurement, the measured
and calculated reflectance spectra are displayed on the graph. The thickness of the films are listed in
the boxes labeled "Layer 1:", "Layer 2:", etc. (actual material names are used if entered in the index
box for each film layer). If any of the thickness values were measured, they are displayed in bold

numbers.

The values of the calculated reflectance versus wavelength are listed in the grid that is viewed by
clicking on “Show Table” at the lower right-hand corner of the screen The calculated n and k values
may be viewed by scrolling through the grid. Clicking on a column containing measured data will
cause it to be plotted on the graph.

Selected data from the results grid may be copied to the clipboard by clicking on "Copy Selected
Data". The wavelength data is copied along with the selected reflectance, n, and/or k data.

Fitting Error

The accuracy of a calculation fit, and thus the reliability of the measurement, can be judged by the
match between the measured and calculated spectra, which is quantified by the Fitting Error value.
The Fitting Error is a normalized average RMS difference between the measured and calculated
spectra points. Of course, the smaller the error value, the better the fit, and the more reliable the
measured values. The actual value of the Fitting Error is quite dependent upon the type of
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measurement being made, but, as a general guideline, a good measurement of thickness and optical
constants occurs when it is in the neighborhood of 0.01 or less.

5.4 The File Menu

File > Open Reflectance Spectrum...
This command is used to open stored reflectance spectra, which are then displayed and can be

analyzed for film properties.
File > Save Measured Spectrum...

This command is used to save measured reflectance spectrum for export or later analysis. All data is
saved along with the corresponding wavelength data in comma-delimited format.

File > Save Calculated Spectrum...
This command is used to save the calculated reflectance spectrum for export or later analysis. All
data is saved along with the corresponding wavelength data in comma-delimited format.

5.5 The Edit Menu

Edit > Copy Measured Spectrum...
This command is used to copy the Measured reflectance spectrum and corresponding wavelength

data in comma-delimited format.

Edit > Copy Calculated Spectrum...
This command is used to copy the calculated reflectance spectrum and corresponding wavelength

data in comma-delimited format.

Edit > Material Library...

The files that FILMeasure uses to describe n and k of different materials can be edited by selecting
Edit > Material Library... The files that are used to describe n and the material type (e.g., dielectric,
semiconductor, metal) are designated index files and have the extension “.nnn”. The files that
describe k have the extension “.kkk”.
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. Edit File: 5102

1543

162376
1.50841
1.50004
1.49404
148719
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147512
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148429
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1.45008
145885
1.45841

Figure 5.3: The Edit > Material Library dialog box

Edit > Units...
The thickness (length) units used to describe structures and display results are chosen here. The
choices include nanometers (nm, 10e-9 m), microns (um, 10e-6 m), angstroms (A, 10e-10 m), and

kilo-angstroms (kA, 10e-7 m).
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5.6 The Setup Menu

Figure 5.4: The Setup > Data Acquisition dialog box

Setup > Data Acquisition: Integration Time

This control is used when manually setting the integration time (i.e., when not using Automatic
Integration Time.) To set the integration time, make sure that "Use Background" and "Use
Reference" are not checked and enter a time into the “Integration Time” field and click OK. A value
of 100 ms is a good starting point. To facilitate rapid adjustment of the integration time, select
Acquire > Start Continuous Acquisition. FILMeasure will now be continuously acquiring and
displaying scans. If the scan is off-scale select Setup > Graph Options... and “AutoScale Y axis” to
rescale the axes. Now turn the light source on and insert a test sample. The vertical scale of the
spectrum extends from zero to 4095 (since the A-to-D conversion uses 12 bits). Thus, a good
working level is when the peak height of the sample being measured, or the reference sample, which
ever is greater, is 3000-3500 counts (Note: if the reference measurement saturates, spurious final
measurements will result). If the maximum signal is too low, increase the integration time.

Setup > Data Acquisition: Reference Material

Enter here the reflectance (or transmissivity if in transmission measurement mode) value of the
reference sample used. For transmission measurements, enter 1.0. For reflectance measurements, the
reflector should have known reflectance characteristics over the region of interest. The reflectance
versus wavelength values should be entered into a text file with the extension ".rrr" (stored in the
"Material" subfolder). Materials that already have “.rrr” extensions are available by selecting from
the list in the "Reference Material" field.

Setup > Data Acquisition: Take Dark
This button allows the dark portion of the baseline measurement to be taken without having to re-

take the reference measurement.
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Setup > Data Acquisition: Take Reference
This button allows the reference portion of the baseline measurement to be taken without having to

re-take the dark measurement.

Setup > Data Acquisition: Subtract Dark
This feature allows the dark subtraction portion of the baseline correction to be disabled.

Setup > Data Acquisition: Use Reference
This feature allows the reference portion of the baseline correction to be disabled..

Setup > Data Analysis: Data Smoothing

This is essentially a function that averages together a number of data points on either side of each
measured data point. For example, if the “Smoothing Points” is set to 5 then each data point
displayed on the screen is actually an average of five data points (the data point plus the two data
points on either side). This function can be used to reduce noise when reflectance signals are very

weak.

Setup > Data Analysis: Scans to Average

In order to get the low noise spectrum it is occasionally necessary acquire a number of reflectance
spectra and display their average. This is readily accomplished by setting the “Scans to Average”
field.

Setup > Access Control...

The software for the F20 incorporates password protection to limit access to the measurement
software and settings. When the software is initially installed the access control is turned off. The
software will automatically boot up with Engineer level access which enables access to all features of
the program except turning on and off access control and adding and deleting users.

The access control options are accessed from the Set Up menu. Turning on access control requires
Supervisor level access. The software is delivered with one user, a supervisor, .in the list of
authorized users as shown below:

UserID: filmsuper
Password: filmetricsfff

To turn on access control, log in as filmsuper using the password shown above. The “Activate
Access Control” check box should now be enabled. By placing a check mark in the Activate Access
Control check box access control will be active.

You should also create some users at this time. To add an operator level user, select operator from
the access level list box, type a user name and type an initial password for that user. Then click the
Add User button. To add an engineer or a supervisor user follow the same procedure, but pick the
appropriate access level from the list box before pressing the Add User button.

To Delete a user, enter the UserID and press the Delete User button.

Operator and Engineer level users can change their passwords when they are logged in by entering
their password into the password box and pressing the change button. Supervisor-level users can
change their password or the password of any other user by selecting the appropriate access level,
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entering the appropriate UserID and the new password and pressing Add User. If the program finds
that a user already exists, it will delete the old entry for that user and create a new entry.

We recommend that you create a new supervisor level user and delete the filmsuper user for
maximum security. If all supervisor level users forget their passwords, it will be necessary to re-
install the software and add all the users again.

Setup > Graph Options: Axis Fields

The "Graph Options" dialog box may also be accessed by double-clicking on the graph display. The
Horizontal Axis Minimum and Maximum fields are used to control the wavelength range displayed
on the screen. The selected range also controls the range of wavelengths that FILMeasure analyzes
when determining film properties. Use the Vertical Axis Minimum and Maximum fields to control
the vertical-axis display. Check the Autoscale Y axis box to activate y-axis autoscaling. The lower
value is always O for autoscaling, the maximum y-axis upper limit is 5000.

Setup > Graph Options: Display n and k on One Graph

Check this box to cause n and k to be graphed together on the same plot. If this option is not checked
n will be graphed along with the initial guess for n and k with the initial guess for k. Scroll the
spreadsheet displaying wavelength, n and & left or right to plot » or k on the graph.
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Chapter 6 How to Contact Us

We welcome suggestions from our users on ways to improve our software and hardware. Please send
! us any suggestions you may have for improvements in the manual or new features you would like to

see in the software.

| We may be reached by phone at 619-554-0005, by fax at 619-554-1311, or by e-mail at
support @filmetrics.com.
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Appendix A Performance Specifications

Thickness Measurement Range

F20 150 A to 50 um
F20UV 50 A to 50 um
Optical Constant Measurement Range

F20 1000 A to 10 um
F20-UV 200 A to 5 um
Spot Size

Adjustable 500 pm to 1 cm

Thickness Accuracy’
+/- 1 nm at 500 nm thickness

Precision?
0.1 nm

Repeatability3
0.07 nm

' Thermally grown SiO, on Si.

> Standard deviation of 100 thickness readings of 500 nm SiO, film on silicon substrate. Value is average of
standard deviations measured over twenty successive days.

* Two sigma based on daily average of 100 readings of 500 nm SiO, film on silicon, measured over twenty
successive days.
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Appendix B Theory of Operation

Measurement Theory

The F20 measures thin-film characteristics by either reflecting or transmitting light through the
sample, and then analyzing this light over a range of wavelengths. Because of its wave-like
properties, light reflected from the top and bottom interfaces of a thin-film can be in-phase so that
reflections add, or out-of-phase so that reflections subtract. Whether the reflections are in- or out-of-
phase (or somewhere in between) depends on the wavelength of the light, as well as the thickness
and properties of the film (e.g., reflections are in-phase when A = (2*n*d)/i, where A is the
wavelength, n is the refractive index, d is the film thickness, and i is an integer.) The result is
characteristic intensity oscillations in the reflectance spectrum (see Fig. B.1.) In general, the thicker
the film, the more oscillations there are in a given wavelength range.

0-5 T T T T T T T T ! T T T T I T T T T ( T T

e R
3
s
A I IR N TN N T T N

l l/ 1 /
| | \ // . o,
,I! l‘ ”/ l‘i\ / \\ i// \\\\
Refl I R B / \ / \
erl. il L \ / \ / \
o (. | / | /
iy v | / \ / \
L v \ , \ ]
i ‘\\ /,’ Vo \ / \
| \‘ \ i \’r
\ ! \
- A4 \\\/1/ =
_ Reflections Out-of-Phase i
O L 1 | I | L 1 ] 1 | L | | L | L L 1. I l ! 1
400 500 600 700 800

Wavelength(nm)

Figure B.1: Example of Reflectance Spectrum with Oscillations
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The amplitude of the oscillations is determined by the refractive index and extinction coefficient of
the films and substrate. Therefore, by analyzing the period and amplitude of these oscillations, the
F20 can determine thickness and optical properties (n and k) of multiple thin-films.

Thickness Measurement Details

Optical thin-film thickness measurements require the successful completion of two tasks: acquisition
and then analysis of an accurate reflectance spectrum. To determine film thickness, FILMeasure
calculates a reflectance spectrum that matches as closely as possible the measured spectrum.
FILMeasure begins with an initial guess for what the reflectance spectrum should look like
theoretically, based on the user’s input of a film structure for the sample. Then FILMeasure varies
the parameters it is solving for until the calculated reflectance spectrum matches the measured data.
Mathematically, this procedure is complicated by the fact that as the thickness of the films in the
calculation is varied there can be many near matches. Therefore, an approach that simply homes in
on a solution by finding successively better approximations will not work unless the starting guess
for optical thickness is within approximately 1000 A if the actual thickness.

In measuring thickness only, FILMeasure avoids homing in on a false solution by searching the
entire acceptable thickness range to determine the thickness which gives the best possible match
between the measured and calculated spectra. The thickness range searched is determined by the
initial guess for thickness together with the thickness constraint. If no thickness is entered for an
initial guess, FILMeasure will search the entire thickness range from 0 to 100 microns. Since the
time to find a solution is proportional to the range of thicknesses being searched it is beneficial to
provide an initial guess for the thickness of the films to be measured.

Optical Constant (n and k) Measurement Details

Measurement of optical constants (refractive index and extinction coefficient, also called n and k)
requires a simultaneous determination of film thickness. The exception to this is for measurement of
a bare substrate. The approach used by FILMeasure to determine film thickness and optical
constants is the same as that used to measure thickness alone, except that now » and k are also varied
to optimize the match between calculated and measured reflectance spectra.

Since n and k vary as a function of wavelength, it is necessary to solve for them at every wavelength.
For a completely unknown material it is not possible to do this using a reflection spectrum only since
at each wavelength only one know parameter (reflectance) is known and there are two unknowns (n
and k). However, n and k are not independent, but are related to each other via what is known as the
Kramers-Kronig relation. If n were known at all wavelengths, k could be computed solely from 7.
Since it is only possible to measure » over a finite wavelength range, k cannot be computed directly
from n.

In reality, however, there is plenty of data present from a single reflection spectrum to determine
both n and k simultaneously. This is due to the fact that the refractive index at any given wavelength
is not independent of the refractive index at adjacent wavelengths, but follows a smooth dependency
that can be accurately modeled by a theoretical equation. Furthermore, if there is an equation for
refractive index it can be transformed using the Kramers-Kronig relations to yield k. Thus, if the
equation for refractive index has three adjustable parameters it is only necessary to adjust these three
parameters, plus the thickness in order to match the calculated and measured spectra.
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Therefore, the measurement of » and k has been reduced to choosing an appropriate model for n and
k as a function of wavelength and then adjusting the parameters in the model to obtain a good fit to
the measured data. FILMeasure uses different models depending on the type of material being
measured.

The parameter space being searched to find a solution is potentially quite large since it involves
thickness plus the adjustable parameters of the model. Furthermore, since there are many near-
matches as the thickness in the model is varied, it is important to reduce the parameter space being
searched. This is done by homing in on the match closest to the initial guess. This will only be the
correct solution if the initial guess for thickness is within about ¥2 wavelength of the correct value.
To permit more robust solution FILMeasure can search the entire constrained thickness range to
determine the correct thickness before it begins solving for n and k. This initial search feature is
enabled by checking one of the appropriate search mechanisms in the “Edit Structure” options dialog

box.

F20 Hardware Operation
The F20 performs two distinct functions: data acquisition and data analysis. Data analysis specifics
are discussed in Chapter 5. In this section we describe how the F20 acquires accurate spectral

reflectance data.

Light is supplied by a tungsten-halogen bulb that generates light from approximately 400 nm to 3000
nm. This light is delivered to and collected from the sample through a fiber-optic cable bundle and a
lens. The intensity of the reflected light is measured at 512 different wavelengths with a
spectrometer. The F20 spectrometer uses a diffraction grating to disperse the light and a linear
photodiode array to measure the light at the different wavelengths. The photodiode array operates by
integrating the current generated by light falling on each of the 512 pixels. After a user-selectable
integration time, the accumulated charge in each photodiode is read by the computer. Because a
longer integration time results in a larger charge, it is the integration time that determines the
sensitivity of the spectrometer. Adjustment of the integration time is used to obtain the proper signal
level. Too short an integration time results in a weak, noisy signal, while too long of an integration
time results in a saturated signal.

The Baseline Measurement
The baseline measurement allows the FILMeasure software to take into account the response

inherent to the F20 reflectance measurement hardware. It does this by measuring a reference sample
and by taking a “dark” reading. In any optical system there are many components whose
characteristics vary with wavelength (e.g., the output of the light source and the sensitivity of the
spectrometer). However, when reflectance measurements are made, only variations in reflectance vs.
wavelength due to the sample under test are of interest. Therefore, FILMeasure must perform a
calibration to determine the spectral response of the system. This is done by making a measurement
of a "reference” sample that has known reflectance characteristics. Note that it is not necessary for
the reference sample to be the same as the substrate upon which films to be measured reside. The
only purpose served by the reference sample is to permit calibration of the optical system. For
example, it is possible to use a Si wafer as the reference sample and then measure films on GaAs,
InP, glass, plastic, etc.
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After the reference measurement is made a dark reading is taken. A non-zero dark level is due to
current leakage inherent to photodiodes, which causes each photodiode in the array slowly charges
up even when no light enters the spectrometer. Thus, in order to make an accurate measurement of
the light entering the spectrometer, it is necessary to subtract this "dark" current contribution. This is
the purpose of the "dark" reading, which measures the magnitude of the dark current for a given
integration time. When a "dark" measurement is made, a spectrum is measured that represents the
signal generated by the spectrometer when a sample of zero reflectance is measured. To simulate a
sample with zero reflectance during a "dark" measurement, a specularly reflecting sample can be
held at an angle with the light source turned on, or in many cases the light source may simply be
turned off momentarily during the dark measurement.

Due to drift in the light source and temperature of the spectrometer electronics, it is a good idea to
take a baseline periodically.
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AppendixC  Optional Features

C.1 Measuring Optoelectronic Devices

VCSEL cavity resonance dips and distributed Bragg reflectors (DBRs) may be measured by selecting
"Opto Values" from the "Measure:" list. To measure laser cavity resonance dips, select "Cavity
Dips" from the "Find:" list. This routine works by finding the wavelength that corresponds to the
minimum reflectance in a pre-determined wavelength range. The wavelength range that is searched
can be restricted in one of two ways, which are selectable in the Cavity Dip "Setup" dialog box. The
simplest way to restrict the wavelength range is to manually specify the range. The second is to
restrict the search to the range between the lowest wavelength above a given reflectance value and
the highest wavelength above a second (usually identical) reflectance value. The upper and lower
limits of the search are displayed on the screen, along with the cavity dip location.

The location of the center wavelength and the bounding reflectance minima of a DBR may be
measured by selecting "DBR Center" from the "Find:" list. The reflectance threshold for finding the
mirror minima can be specified with the DBR Center Setup box. This is especially useful when
measuring multiple and convoluted DBR structures.

C.2 Measuring Filters

The cut-off wavelengths of high-pass, low-pass, band-pass, and notch filters may be measured by
selecting "Filters" from the "Measure:" list. Filter measurements are made by taking appropriate
reference and dark readings as described in Section 6.1, and clicking on "Measure". Measurement
parameters are set on the main screen. The wavelength range searched is restricted to that displayed
on the screen, which is determined by the "Graph Limits" dialog box, which is found under the
"Setup" menu.
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Appendix D Light Bulb Replacement

Warning: Hazardous voltages are present within the unit. Never attempt any
maintenance without disconnecting the power cord.

Step by step:

1. Exit FILMeasure program and turn off your computer.

2. Disconnect power cable from the F20/30/40/50, and the DB25 signal cable from the back
of the unit,

3. Disconnect fiber optic cables from the front of the unit.

4. Turn the unit over and remove the four recessed screws opening the two halves of the
enclosure.

Warning: Caution, avoid touching any interior components, other than the lamp, lamp base
and housing.

5. Loosen lamp set screw (counter clockwise to loosen).
Insert new lamp fully into lamp housing. Do not touch the lamp glass.
Secure lamp with set screw (clockwise). Do not over tighten.

Plug new lamp into the lamp power connector. Do not test lamp with lid removed.

© © N o

Replace the unit’s top cover and screws. Insert cord into wall supply and test light.
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Appendix E Automation and Data |I/O

Measurements can be automated and additional data analysis can be performed by user-supplied
software that communicates with FILMeasure via Dynamic Data Exchange (DDE). An example
program illustrating how to use DDE with FILMeasure is located in the “Client” folder, which is
inside the “FILMeasure” folder. Although the example program is written in Visual Basic, DDE-
based automation software can be written in any language that supports DDE. A single data entry is
linked and is used to return information from FILMeasure to the client application. Once the link is
set up, FILMeasure will also execute commands specified by the client application. To set up a link
to FILMeasure set up a DDE conversation as follows:

LinkTopic = "FILMeasurelFILMeasureDDE"
LinkItem = "DDESourceBox"

Although all commands are listed below, commands that refer to measurement options not included
with a particular system will not be available. For example, the commands dealing with OptoValues
measurements are only available in FILMeasure versions containing the “Measure: OptoValues”
option. The commands understood by FILMeasure are as follows:

AnalyzeLayer - Equivalent to pushing the thickness analyze button. This command can be useful for
testing DDE applications.

AnalyzeOpto - Equivalent to pushing the OptoValues analyze button. This command can be useful
for testing DDE applications.

CopySpectrum - Copies currently displayed spectrum onto the clipboard
GetRMSError - Updates the linked data to be the RMSError resulting from the last measurement.

GetThickness(<arg>) - Updates the linked data to be the measured thickness of the film specified by
<arg>.

MeasureLayer - Equivalent to pushing the thickness Measure button. Updates the linked data to be
the measured thickness of film 1 when finished measuring.

MeasureOpto - Equivalent to pushing the OptoValues Measure button. Updates the linked data to be
the measured position of DBR or FP parameter specified.

MeasureSpectrum - Equivalent to pushing the Spectrum Measure button. Copies measured
spectrum to the clipboard.

OptoDBRThreshold(<argl>) - Sets the percentage threshold for DBR measurements to the value
specified by <argl>.
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OptoDBRThresholdMode(<arg1>) - use 0 in <argl> to specify percentage of absolute reﬂectance
use 1 to specify percentage of maximum reflectance.

OptoFPMeasurementMode(<arg1>) - use 0 in <argl> to specify measuring based on a percentage
of the maximum or absolute reflectance, use 1 to specify measuring restricted by wavelength.

OptoFPReflectanceLimits(<arg1>,<arg2>) - use <argl> and <arg2> to specify the lower and upper
reflectance limits.

OptoFPReflectanceThresholdMode(<arg1>) - use 0 in <argl> to use the Absolute option, use 1 to
use the Maximum option.

OptoFPWavelengthLimits(<arg1>,<arg2>) - used to set the lower and upper wavelength limits.
OptoMeasurementMode(<arg1>) - use 0 to select cavity dip, use 1 to select DBR peak.

SetThickness(<arg1>,<arg2>) - Sets the initial guess thickness of the film specified by <argl> to the
thickness value specified by <arg2>. Updates the linked data to be the thickness value given in

<arg2>.
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